I tried to use flash on my Mac, but I got an error.

Asked 2 months ago, Updated 2 months ago, 3 views

When I used flash on my Mac, a warning came out and I am looking for a solution.
The code is as follows:

$flask run

* environment:production
  WARNING: Do not use the development server in a production 
  environment.
Use a production WSGI server installed.
* Debug mode:off
* Running on http://127.0.0.1:5000/(Press CTRL+C to quit)
127.0.0.1 - [24/May/2019 15:29:02] "GET/HTTP/1.1" 200 -
127.0.0.1 - [24/May/2019 15:29:05] "GET/HTTP/1.1" 200 -
127.0.0.1 - [24/May/2019 15:29:06] "GET/HTTP/1.1" 200 -
127.0.0.1 - [24/May/2019 15:29:16] "GET/HTTP/1.1" 200 -
127.0.0.1 --- [24/May/2019 15:29:19] "GET/HTTP/1.1" 200 --

python3 macos flask

2022-09-30 11:16

1 Answers

Use a production WSGI server installed.

The solution is also displayed with a warning.
The Web server built into the flash is vulnerable, so I think it is recommended to use it in conjunction with WSGI servers such as gunicorn and uWSGI in the production environment.


2022-09-30 11:16

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.