Apache Service detected with wrong path when starting XAMPP

Asked 2 months ago, Updated 2 months ago, 8 views

The following error appears:

 8:05:47 [Apache] Apache Service detected with wrong path
8:05:47 [Apache] Change XAMPP Apache and Control Panel settings or
8:05:47 [Apache] Uninstall/disable the other service manual first
8:05:47 [Apache] Found Path: "c:\Apache24\bin\httpd.exe" -k runservice
8:05:47 [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice

I installed apache once before, but it was simple to copy it to drive C, so I deleted the folder to uninstall it, but is it not possible to delete it in the FoundPath section of the error?I don't know how to delete the old apache...is there any other countermeasures?

Add from Comments

As you pointed out, I changed it, but I got the following error.

 21:56:58 [Apache] Found Path: "c:\xampp\bin\httpd.exe" -k runservice 
21:56:58 [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice 
21:56:58 [Apache] Problem detected! 21:56:58 [Apache] Port 80 in use by "c:\xampp\bin\httpd.exe "-k runservice" with PID 6452!
21:56:58 [Apache] Apache WILL NOT start without the configured ports free! 
21:56:58 [Apache] You need to uninstall/disable/reconfigure the blocking application 
21:56:58 Apache or configure Apache and the Control Panel to listen on a different port

apache xampp

2022-09-30 11:17

3 Answers

Apparently, Apache, which was previously installed, is still registered as a service.

If the Apache Service column is checked when you launch the XAMPP Control Panel with administrator privileges, you can unregister the service by clicking it and selecting Yes in the dialog that appears.

Enter a description of the image here

If it is not checked...

  • Install Apache in the same location and execute the following command from a command prompt launched with administrator privileges:

    cd/dc:\Apache24\bin (Note: Installation destination\bin)
    httpd-k stop
    httpd-kuninstall
    
  • or manually stop or delete services

    1. Run to services.msc with a filename, locate the service named Apache, and double-click to open the property
    2. Verify that the executable path is the same as the previously installed location
    3. Press Stop if you can.Remember the service name (probably Apache 2.4)
    4. Run the scdelete service name at the command prompt launched with administrator privileges

Install Apache in the same location and execute the following command from a command prompt launched with administrator privileges:

cd/dc:\Apache24\bin (Note: Installation destination\bin)
httpd-k stop
httpd-kuninstall

Alternatively, stop or delete services manually

Problem detected!21:56:58 [Apache] Port 80 in use by "c:\xampp\bin\httpd.exe "-k runservice" with PID6452!
Apache WILL NOT start without the configured ports free!

It seems that Apache other than XAMPP is already started.It seems to have been started as a service, so I think it's easy to stop at services.msc as above.
(Or restarting is a good idea.)

Then you can either fix it to the correct path or unregister it once.


2022-09-30 11:17

It's competing with the previous installation, right?
For example, change the XAMPP port...
Add the old Apache again and try uninstalling it again.

Just in case, there was an article about the same problem, so I will share it with you.
However, you will have to edit the registry, so please be careful

HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->services->
Change the Apache 2.4->ImagePath
value to "c:\xampp\bin\httpd.exe"-k runservice

http://vlpius.hatenablog.com/entry/2014/08/26/135929

It looks like you've tried how to link the article to
There is a difference between the link and the questioner's environment.
As stated in the error content,
In your environment, isn't the path of httpd below?

x:"c:\xampp\bin\httpd.exe" -k runserviceChange to
○:Change to "c:\xampp\apache\bin\httpd.exe"-k runservice

Also, there is an answer from Mr./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms./Ms. If you let me know that it didn't work, I will be able to understand the situation of the questioner and solve it easily.


2022-09-30 11:17

The reason seems to be the uninstallation of XAMPP from the Windows control program and functionality.
Uninstalling XAMPP again in a legitimate manner should resolve the issue.

C:\XAMPP\uninstall.exe.Uninstall using this uninstall.exe.
Once done, Windows will continue to reboot.
Reinstall XAMPP after Windows reboots.

XAMPP Apache should succeed.


2022-09-30 11:17

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.