Understanding Cartopy Installation Errors on Pip

Asked 2 months ago, Updated 2 months ago, 10 views

I installed [email protected] and other site-packages on Brew and tried to install cartopy on pip.I also checked the version, but it didn't work when I installed pip.The contents of the error are below.If anyone knows the solution, please let me know.

>Collecting cartopy
  Using cached Cartopy -0.20.1.tar.gz (10.8 MB)
  Installing build dependencies... done
  Getting requirements to build wheel... error
  ERROR: Command errored out with exit status 1:
   command: /opt/homebrew/opt/[email protected]/bin/python3.9/opt/homebrew/lib/python3.9/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_wheel/var/folders/yw/rbz_tbnpnp0ml00000
       cwd: /private/var/folder/yw/r71bkb_n1ml4y0wpx_h9pzd00000gn/T/pip-install-4umjbxq _/cartopy_a90c6a6e442b199df64668db
  Complete output (34 lines):
  Traceback (most recent call last):
    File"/opt/homebrew/lib/python 3.9/site-packages/pipe/_vendor/pep517/in_process/_in_process.py", line 363, in<module>
      main()
    File"/opt/homebrew/lib/python 3.9/site-packages/pipe/_vendor/pep517/in_process/_in_process.py", line 345, in main
      json_out ['return_val'] = hook(**hook_input ['kwargs'])
    File"/opt/homebrew/lib/python 3.9/site-packages/pipe/_vendor/pep517/in_process/_in_process.py", line 130, get_requires_for_build_wheel
      return hook(config_settings)
    File"/opt/homebrew/Cellar/python @3.9/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python 3.9/site-packages/setuptools/build_meta.py", line 154, input_requires_for_build_wheel
      return self._get_build_requires(
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/setuptools/build_meta.py", line 135, in_get_build_requires
      self.run_setup()
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/setuptools/build_meta.py", line 150, in run_setup
      exec(compile(code,__file__, 'exec'), locals())
    File "setup.py", line 326, in<module>
      setup(
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/setupools/__init__.py", line 159, in setup
      return distutils.core.setup(**attrs)
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/distutils/core.py", line 108, in setup
      _setup_distribution=dist=kclass(attrs)
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/setupools/dist.py", line453, in_init__
      _Distribution.__init__(
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/distutils/dist.py", line 292, in__init_
      self.finalize_options()
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/setupools/dist.py", line830, finalize_options
      for ep in sorted (loaded, key=by_order):
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python 3.9/site-packages/setupools/dist.py", line 829, in<lambda>
      loaded=map(lambdae:e.load(),filtered)
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/pkg_resources/_init___.py", line 2454, install
      self.require(*args,**kwargs)
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/pkg_resources/_init___.py", line2477, require
      items=working_set.resolve(reqs, env, installer, extras=self.extras)
    File"/opt/homebrew/Cellar/[email protected]/3.9.7_1/Frameworks/Python.framework/Version/3.9/lib/python3.9/site-packages/pkg_resources/_init___.py", line 782, in resolve
      raise VersionConflict(dist,req).with_context(dependent_req)
  pkg_resources.ContextualVersionConflict: (pyparsing 3.0.4(/opt/homebrew/lib/python 3.9/site-packages), Requirement.parse('pyparsing<3,>=2.0.2'), {'packaging'})

python python3 macos pip

2022-09-30 13:58

1 Answers

In the case of Anaconda, it has now been repaired.

conda install-conda-forge cartopy


2022-09-30 13:58

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.