Could not find rake-12.0.0 in any of the sources error when rails-v occurs

Asked 1 months ago, Updated 1 months ago, 2 views

I am making an app for rails.
When I try to check the rails version, I get the following error:

:/var/www/myapp/development/current$rails-v
Could not findrake-12.0.0 in any of the sources
Run `bundle install` to install missing gems.

The Gemfile is as follows.Bundle installation does not change the result.
Why don't you return the rails version?

If anyone knows, please let me know.

Gemfile

gem 'rails', '5.0.3'
gem 'will_paginate', '3.1.0'
gem 'bootstrap-will_paginate', '0.0.10'
gem'bootstrap-ass', '~>3.3.6' 
gem'sass-rails', '>=3.2'
gem 'puma', '3.4.0'
gem 'uglifer', '3.0.0'
gem 'coffee-rails', '4.2.1'
gem 'jquery-rails', '4.1.1'
gem 'turbolinks', '5.0.1'
gem 'jbuilder', '2.4.1'
gem 'devise'
gem 'toastr-rails'
gem 'omniauth'
gem 'omniauth-facebook'
gem 'omniauth-twitter'
gem 'omniauth-google-oauth2'
gem 'paperclip'
gem 'geocoder'
gem 'jquery-ui-rails', '5.0.5'
gem 'private_pub'
gem'thin'
gem 'ransack'
gem 'font-awesome-rails'
gem 'font-awesome-sass'
gem 'rails-i18n'
gem'payjp'
gem'carrierwave'
gem'rmagic'
gem 'rack-mini-profiler'
gem'rb-readline'
gem 'unicorn'
gem 'capistrano', '~>3.6'
gem 'capistrano-rails', '~>1.3'
gem 'capistrano-bundler'
gem 'capistrano-passenger'
gem 'capistrano-rbenv'
gem'therubyracer', platforms::ruby
gem'capistrano3-unicorn'
gem'capistrano-safe-deploy-to'
gem 'listen', '~>3.1.5'
gem'sqlite 3', '1.3.13'

group —Development do
  gem 'web-console', '3.1.1'
  gem 'spring', '1.7.2'
  gem 'spring-watcher-listen', '2.0.0'
end

group —test do
  gem 'rails-controller-testing', '0.1.1'
  gem 'minitest-reporters', '1.1.9'
  gem 'guard', '2.13.0'
  gem'guard-minitest', '2.4.4'
end

group —Production do
  gem 'pg', '0.18.4'
  gem 'rails_12 factor'

The specs are:

ubuntu 16.04
Bundler 1.14.6
ruby 2.4.1p111 (2017-03-22 revision 58053) [x86_64-darwin16]
Rails 5.0.3
capistrano3
cloud9 (local environment)
nginx 1.10.3-0 ubuntu 0.16.04.2
unicorn 4.9.0-2build2

ruby-on-rails ruby

2022-09-30 14:02

1 Answers

ruby on rails - Your bundle is locked to rake (12.0.0), but that version could not be found in any of the sources listed in your Gemfile. - Stack Overflow
is a similar error.

https://stackoverflow.com/a/41757322/1979953

as answered in

Step 1:

gem install rubygems-bundler
gem regenerate_binstubs

Step 2:

deleting vendor/bundle directories

bundle install for rebuild

Step 3:

Try gem update bundleer

Related Issues: https://github.com/bundler/bundler/issues/5068


2022-09-30 14:02

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.