Poweroff (virtualbox) appears when creating virtual machines in Vagrant and VirtualBox

Asked 2 months ago, Updated 2 months ago, 5 views

I am trying to create a virtual machine using Vagrant and VirtualBox, but an error occurred and I cannot proceed.

Books for reference:
"WordPress Textbook to Create and Learn Business Sites" Page 19

My PC uses a Mac and I have already checked the author's book.

Poweroff (virtualbox) is displayed even if you execute the following command:
Ideally, running (virtualbox) should be displayed.

Runtime log (whole):

Last login:Thu Nov 11 14:34:52 ontys000

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh-s/bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
keyi-no-MacBook-Air: ~kei$cd/Users/kei/Desktop/
keyi-no-MacBook-Air —Desktop keyi$mkdir pacificmall
keyi-no-MacBook-Air —Desktop keyi$cd pacificmall
keyi-no-MacBook-Air: pacificmall keyi$vagrant init prime-strategy/kusanagi-wp5 --box-version 1.0
A`Vagrantfile`has been placed in this directory.You are now
ready to `vagrant up` your first virtual environment! Please read
The comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.
keyi-no-MacBook-Air: pacificmall keyi$ls
Vagrantfile
keyi-no-MacBook-Air: pacificmall keyi$vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==>default: Importing base box 'prime-strategy/kusanagi-wp5' ...
==>default: Matching MAC address for NAT networking...
==>default: Checking if box 'prime-strategy/kusanagi-wp5' version '1.0' is up to date...
==>default: There was a problem while downloading the metadata for your box
==>default: to check for updates. This is not an error, since it is useful due
==>default: to temporary network problems. This is just a warning. The problem
== > default: encountered was:
==>default: 
==>default:SSL certificate problem:self-signed certificate in certificate chain
==>default: 
==>default: If you want to check for box updates, verify your network connection
==>default: is valid and try again.
==>default: Setting the name of the VM:pacificmall_default_1636615684491_31898
==>default: Clearing any previously set network interfaces...
The IP address configured for the host-only network is not with the
allowed ranges.Please update the address used to be with the allowed
Ranges and run the command again.

  Address: 192.168.33.10
  Ranges: 192.168.56.0/21

Valid ranges can be modified in the /etc/vbox/networks.conf file.For
more information including valid format see:

  https://www.virtualbox.org/manual/ch06.html#network_hostonly
keyi-no-MacBook-Air: pacificmall keyi$vagrant status
Current machine states:

default poweroff (virtualbox)

The VM is powered off. To restart the VM, simple run `vagrant up`
keyi-no-MacBook-Air: pacificmall keyi$ 

Vagrantfile

#-*-mode:ruby-*-
# vi:set ft=ruby:

# All Vagrant configuration is done below. The "2" in Vagrant.configure
# configurations the configuration version (we support older styles for
# backwards compatibility).Please don't change it unless you know what
# You're doing.
Vagrant.configure("2") do | config |
  # The most common configuration options are documented and commented below.
  # For a complete reference, please see the online documentation at
  # https://docs.vagrantup.com.

  # Every Vagrant development environment requirements a box.You can search for
  # boxes at https://vagrantcloud.com/search.
  config.vm.box="prime-strategy/kusanagi-wp5"
  config.vm.box_version="1.0"

  # Disable automatic box update checking.If you disable this, then
  # boxes will only be checked for updates when the user runs
  # `vagrant box updated`. This is not recommended.
  # config.vm.box_check_update=false

  # Create a forwarded port mapping which allow access to a specific port
  # without the machine from a port on the host machine. In the example below,
  # accessing "localhost:8080" will access port 80 on the guest machine.
  # NOTE: This will enable public access to the opened port
  # config.vm.network "forwarded_port", guest:80, host:8080

  # Create a forwarded port mapping which allow access to a specific port
  # without the machine from a port on the host machine and only allow access
  # via 127.0.0.1 to disable public access
  # config.vm.network "forwarded_port", guest:80, host:8080, host_ip:"127.0.0.1"

  # Create a private network, which allow host-only access to the machine
  # using a specific IP.
  config.vm.network "private_network", ip: "192.168.33.10"

  # Create a public network, which generally matched to bridged network.
  # Bridged networks make the machine appear as another physical device on
  # Your network.
  # config.vm.network "public_network"

  # Share an additional folder to the guest VM. The first argument is
  # The path on the host to the actual folder. The second argument is
  # The path on the guest to mount the folder. And the optional third
  # argument is a set of non-required options.
  # config.vm.synced_folder "../data", "/vagrant_data"

  # Provider-specific configuration so you can fine-tune variable
  # backing providers for Vagrant. These export provider-specific options.
  # Example for VirtualBox:
  #
  # config.vm.provider "virtualbox" do | vb|
  #   #Display the VirtualBox GUI when booting the machine
  #   vb.gui=true
  #
  #   #Customize the amount of memory on the VM:
  #   vb.memory="1024"
  # end
  #
  # View the documentation for the provider you are using for more
  # information on available options.

  # Enable provisioning with a shell script.Additional provisioners such as
  # Ansible, Chef, Docker, Puppet and Salt are also available. Please see the
  # documentation for more information about their specific syntax and use.
  # config.vm.provision "shell", inline:<<-SHELL
  #   apt-get update
  #   apt-get install-yapache2
  # SHELL
end

IP addresses configured for host-only networks are not in the allowed range.
Update the address used to be within the allowed range and run the command again.

addresses:192.168.33.10
Range: 192.168.56.0/21

Valid ranges can be modified in the /etc/vbox/networks.conf file.
View the Valid Format for more information:

https://www.virtualbox.org/manual/ch06.html#network_hostonly

It says, but I don't know how to do it, does anyone know?

macos vagrant virtualbox

2022-09-30 14:14

1 Answers

This part of the Vagrantfile

config.vm.network "private_network", ip: "192.168.33.10"

When I changed to the following, I was told that it would work.

config.vm.network "private_network", ip: "192.168.56.10"


2022-09-30 14:14

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.