I don't know how to use HHKB for Bluetooth connection in Ubuntu.

Asked 2 months ago, Updated 2 months ago, 3 views

I've been using RealForce (US) in Ubuntu.
I switched to HHKB (US), so I was going to use HHKB for Bluetooth connection, but these two have different keyboard mappings, so I need to set them up again.

I set it up by referring to the following site, but has the keyboard mapping of RealForce connected to USB changed?Or, HHKB doesn't work as expected.

Use HHKB in Ubuntu

I thought it probably didn't work at all because of this USB connection RealForce, so I tried to pull it out and set it up, but the TUI didn't start in dpkg-reconfigure keyboard-configuration and I couldn't set it up in the first place.
From the above, is there only USB connection (because it is hybrid) when using HHKB in Ubuntu?
Or, if I only set the keyboard mapping with a USB connection, will I be able to use Bluetooth after the setting is complete?

add

$cat/etc/default/keyboard results are shown below.
Enter a description of the image here
This should have been the keyboard setting for HHKB, but the layout shown in Display Keyboard Layout is as follows (RealForce layout).
Enter a description of the image here
Therefore, there are various problems with HHKB.
The most fatal thing is that Ctrl becomes CapsLock.
I'm switching from Ctrl+Space on my Mac, so I have a desire to match this and the current situation is fatal.
If you don't understand my intentions in this question, I'm sorry, but I'd appreciate it if you could point it out again.

ubuntu

2022-09-30 14:19

2 Answers

Self-resolved.
Below is a summary of the necessary steps.

First of all, in my case, I had to connect USB with type-c when setting up.
Once configuration is complete, BT connection is perfectly fine.
You can use it normally.

In addition, I was hoping that HHKB would be recognized just like the Mac keyboard layout, so I chose the HHKB for Mac layout.
This won't work at all.
It needs to be modified to "HHKB".
Once logged out, the layout of HHKB has been successfully completed.

And finally, I have used capslock instead of ctrl, so I had to modify it.
Otherwise, Ctrl disappears...

Now you can use HHKB on ubuntu without any problems!
Thank you so much to everyone who gave me advice!


2022-09-30 14:19

I suggest a different way than the way you link.
You do not need Ubutu keyboard settings or fcitx and mozc settings.

I use HHKB Hybrid Type-s in BT, and I use Ubuntu(18.04|20.04), mac.
What the questioner wants to do is bind to switch Japanese?
Keyboard layout settings are omitted

1.DIP Settings

Turn on 2,3,5,6

2.Setting Input Methods

Enter a description of the image here

3.Fcitx Settings

I set it so that I can switch between left and right Alt.

fcitx

If you want to be able to switch to Ctrl+Space, try setting the following
After checking the operation, it was switched without any problems

Enter a description of the image here

You should be able to switch now, so you don't need to configure Mozc


2022-09-30 14:19

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.