An error occurs when you do rails console in ruby on rails.

Asked 1 months ago, Updated 1 months ago, 4 views

railsc
Could not find listen-3.1.5 in any of the sources
Run bundle install to install missing gems.

Listen-3.1-5 is installed.

Using listen 3.1.5

I did everything I searched on Google, but
I can't solve it at all.
Thank you for your cooperation.

ruby-on-rails ruby console

2022-09-30 14:22

1 Answers

As others wrote, there is no information, so I can only answer the problem at the level I expected, but wouldn't it be solved by updating the Gem using listen?

Perhaps the problem is not listen itself.For example, if the guard or something depends on listen and there is an inconsistency in those versions, you will get an error similar to the one above.

bundle update

Or

bundle update guard

It may be possible to resolve this issue.For the part that corresponds to the guard, please check Gemfile.lock for the gem that uses listen.


2022-09-30 14:22

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.