Is it possible to use a combination of Apache 2.4.51 and PHP 5.4 or less?

Asked 1 weeks ago, Updated 1 weeks ago, 290 views

Apache 2.2.17+PHP 5.2.1+CakePHP 1.1.14, created DB-related webs a long time ago.
Due to a vulnerability in Apache, we would like to upgrade to Apache 2.4.51.
I've seen how Apache 2.4.51 works with PHP 5.5.9.

However, at this rate, the CakePHP version is too old to work with PHP 5.5.If you raise the version of CakePHP up to 1.3, PHP 5.4 will work.

On the main subject, is it possible to manage the operation of the combination of Apache 2.4.51, PHP 5.4 or less?
(If possible, I would like to avoid upgrading more than two series of CakePHP versions.)

Related Questions:
For PHP 5.3.3, do I have to use Apache 2.2 instead of Apache 2.4?

Note:
CakePHP Compatible PHP Version List

php apache cakephp

2022-11-22 23:46

1 Answers

The answer will be similar to the related question, but if it is to address the vulnerability,
Both PHP 5.4, CakePHP 1.x are no longer supported and are several generations old.

reference:
PHP release date and support expiration date

PHP 7.3 and earlier versions have already expired their official support period, including security support.

I don't know the OS in the running environment, but for example, Linux may have difficulty obtaining a supported version of the package (mostly the supported version is determined), so I may have to compile and handle it myself.


2022-11-22 23:56

If you have any answers or tips


© 2022 OneMinuteCode. All rights reserved.